LaTeX error messages are broken

I always got the same error (TeX Live 2013, pdfTeX 3.1415926-2.5-1.40.14, the very most up2date version):

(/home/meisterluk/.texlive/texmf-dist/tex/latex/glossaries/dict/glossaries-dict
ionary-English.dict) (./thesis.glsdefs) (./thesis.toc) [1{/home/meisterluk/.tex
live/texmf-var/fonts/map/pdftex/updmap/pdftex.map}] [2] [3]
Chapter 1.
(./prev_work.tex
! Missing number, treated as zero.
<to be read again>
                   {
l.14 the following properties~\cite{biere}
                                          : % page 10
?

This annoyed for like one week because I could not find the error and could not go on with my bachelor thesis. Obviously it has something to do with biblatex (because of \cite), right? I replaced all parts of the bib file, but could not find the error. Now it tried to create a MWE to find the error (to post it to SE) and removed all parts of the TeX file. Finally I found it:

\hypersetup{
  pdftitle={\@title},
  pdfauthor={\@author},
  pdfsubject={SAT solvers in cryptanalysis},
  pdfcreator={\LaTeX},
  pdfkeywords={SAT solver, hash algorithms, differential cryptanalysis},
  urlcolor=[rgb]{0.2,0.2,0.2},
  linkcolor=[rgb]{0.2,0.2,0.2},
  citecolor=[rgb]{0.1,0.1,0.1}
  baseurl={http://lukas-prokop.at/proj/bakk_iaik},
  pdfview=FitV,
  pdflang={en-US},
  unicode,
  breaklinks,
  colorlinks,
  bookmarks
}

Can you see the missing comma as separator after citecolor? Yes, this is the error. citecolor only affects citations and \hypersetup does not see an error.

LaTeX error messages are broken